Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: CLM und php > 5.3

CLM und php > 5.3 4 Jahre 11 Monate her #5057

  • Robert.K
  • Robert.Ks Avatar
  • Offline
  • Senior Boarder
  • Beiträge: 48
  • Karma: 0
N'abend zusammen.

Bei Wikipedia hatte ich folgendes entdeckt:
Auch der Support von PHP 5.3 mit Sicherheitsupdates wurde mit der Veröffentlichung von PHP 5.3.29 am 14. August 2014 eingestellt.
Das hat mich veranlasst den Webspace auf php 5.5 zu setzen. Mit fatalen Folgen:
Die Darstellung der Startseite (Teilnehmerliste) begann mit nachfolgenden Zeilen:
Strict Standards: Declaration of CLMController::display() should be compatible with JController::display($cachable = false, $urlparams = false) in /var/www/meine Seite/components/com_clm/controller.php on line 19
und
Strict Standards: Non-static method CLMText::tiebrFormat() should not be called statically, assuming $this from incompatible context in /var/www/meine Seite/components/com_clm/views/turnier_tabelle/tmpl/default.php on line 135

Und das mit etlichen anderen Meldungen über 100x bevor die Teilnehmerliste angezeigt wird.
Bin dann auf PHP 5.4 runter. Leider ohne Effekt.
Erst mit 5.3 war die Darstellung wieder in Ordnung.

Frage: Fehler vom CLM (inkompatibel mit php > 5.3) oder läuft bei mir eine andere Komponente Amok?

Die lauffähige Konfiguration
Joomla 2.5.27
PHP 5.3.28
MySQL 5.5.31
CLM 1.5.2a

Gruß Robert
Man hat vom Schach gesagt, dass das Leben nicht lang genug dazu ist, - aber das ist ein Fehler des Lebens, nicht des Schachs. (Christian Morgenstern, 1871-1914)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: CLM und php > 5.3 4 Jahre 11 Monate her #5065

  • dau
  • daus Avatar
  • Offline
  • Administrator
  • Beiträge: 128
  • Dank erhalten: 5
  • Karma: 0
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: CLM und php > 5.3 4 Jahre 11 Monate her #5067

  • Robert.K
  • Robert.Ks Avatar
  • Offline
  • Senior Boarder
  • Beiträge: 48
  • Karma: 0
Die Umleitung funtioniert leider nicht.
Vielleicht auf intern konfiguriert?

Gruß Robert
Man hat vom Schach gesagt, dass das Leben nicht lang genug dazu ist, - aber das ist ein Fehler des Lebens, nicht des Schachs. (Christian Morgenstern, 1871-1914)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: CLM und php > 5.3 4 Jahre 11 Monate her #5068

  • dau
  • daus Avatar
  • Offline
  • Administrator
  • Beiträge: 128
  • Dank erhalten: 5
  • Karma: 0
TSchwietert hatte deine Frage ins FAQ gestellt, aber anscheinend nicht für alle freigegeben. Das ist vermutlich ein Versehen:

TSchwietert:
Hallo Robert,
Danke für deine Heinweise !
Ich denke da wird es sich um einen Fehler des CLM handeln. Wir sind gerade dabei alles auf Joomla 3.x kompatibel zu machen und natürlich gibt es dann auch immer mal wieder Fehler im Zusammenhang mit der PHP Version.
Um das zu beheben bin ich allerdings der falsche Ansprechpartner da ich den Fehler nicht deuten kann.

@Marcel : Magst du dich darum kümmern ?

Grüße
Thomas

Darauf folgte eben meine Antwort:

Die genannten Fehler, sind wie im Fehlernamen angegeben, Fehler von den "Strict Standards". Diese werden nur angezeigt wenn Joomla unter Konfiguration/Server bei Fehler berichten auf Maximum (oder je nach Server Konfiguration auch Standard) eingestellt wurde.

Joomla in der Version 2.5 hat übrigens auch manchmal selbst welche, da die Änderungen erst in 5.3 eingeführt wurden und die Warnmeldung ab 5.4 aktiv ist.

Deine Probleme sind also gelöst wenn du diese Option auf Keine einstellst, das ist für ein Produktivsystem sowieso empfohlen.

In der CLM Variante für Joomla 2.5/3.x sind die meisten dieser trivialen Fehler inzwischen behoben und die minimale PHP Version dementsprechend auf 5.3 erhöht.
Auf schachbezirk-siegerland.de befindet sich diese Version unter PHP 5.5 am laufen, ohne dass dafür noch einmal extra Änderungen vorgenommen wurden. Dementsprechend sollte auch die aktuelle CLM Version unter PHP 5.5 ohne Probleme, nur mit einigen Strict Standard Fehlern, laufen.

Ist das Problem damit gelöst?
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: Robert.K

Aw: CLM und php > 5.3 4 Jahre 11 Monate her #5074

  • Robert.K
  • Robert.Ks Avatar
  • Offline
  • Senior Boarder
  • Beiträge: 48
  • Karma: 0
Moin.

Deine Antwort hatte ich der Systemmail bereits entnehmen können.
Nur leider nicht darauf antworten.

Ja, das "Problem" ist damit gelöst.
Läuft jetzt erstmal auf PHP 5.4, da einige Dritt-Module ebenfalls Probleme mit 5.5 haben. Alternativen dazu werden jetzt getestet, da sie auch nicht Joomla 3 kompatibel sind. Danach wird die Version auf 5.5 hochgeschraubt.

Danke.

Gruß Robert
Man hat vom Schach gesagt, dass das Leben nicht lang genug dazu ist, - aber das ist ein Fehler des Lebens, nicht des Schachs. (Christian Morgenstern, 1871-1914)
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Ladezeit der Seite: 0.109 Sekunden
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.
Ok